بروز خطا
   [message]
اشتراک در سوال
رای ها
[dataList]
مشکلات intellij idea 
akram  3 هفته پیش  3 هفته پیش
+1 0

سلام. یکسری از کاربردهای این برنامه واسه من غیرفعاله مثل کاربرد F2 و short open tag و ctrl+E. برای مورد دوم طبق آموزش نصب و فعالسازیو انجام دادم اما جواب نداد.آیا نصب intellij idea ورژن جدیدتر فایده داره یا مربوط به مشکل سیستمه؟ اگه راه حلی دارید ممنون میشم ارائه بفرمایید

0 0
سلام ، لطفاً خطاهای پیش آمده را بنویسید یا تصویری از آنها در همین حا به نمایش بگذارید تا پاسخگویی کنم. سعی کنید فعلاً برای یاد گیری از نرم افزار ها و ورژن هایی که در آموزش ها گفته شده استفاده کنید تا به مشکل نخورید. بعداً که آموزش ها را به اتمام رساندید بهتر است همه ی ابزار ها و تکنیک های خود را بروز کنید. (3 هفته پیش)
+1 0
خطایی بروز نمیکنه فقط به کاربردن مواردی که بیان کردم غیرفعاله مثلا تو reneme کردن یک پارامتر که مثالی داخل آموزش هست و میشه سایر متغیرهای مربوطه رو هم rename کرد برای سهولت و جلوگیری از renameهای بعدی، واسه من عمل نمیکنه یعنی کادر مربوطه باز نمیشه. همینطور با ctrl+E که میشه یک خط رو پاک کرد میزنم عمل نمیکنه. واسه short open tag هم که میشه کدهای php رو داخل نوشت به جای حتی فایل دیگه ای متناسب با ورژن intellij idea دانلود و نصب کردم اما عمل نمیکنه (3 هفته پیش)
0 0
نیازی به تغییر محیط توسعه نیست . باید از setting تهیه شده در آموزش ها استفاده کنید. لینک (3 هفته پیش)
+1 0
همون ابتدای نصب برنامه، اون فایل settings.jar موجود در Disk4 رو هم نصب کردم (3 هفته پیش)
0 0
دوباره فایل تنظیمات را import کنید. و برای short_open_tag به داخل wamp قسمت php و فایل php.ini را باز کنید (بهتر است با intellij idea باز کنید) سپس گزینه ی short_open_tag را به On تغییر دهید. (3 هفته پیش)
+1 0
خیلی ممنونم موارد 1 و 3 ok شدن اما مشکل short open tag برطرف نشد البته قبلا مقدارش رو تو همین ادیتور تغییر داده بودم الآن دوباره انجام دادم و بعدش intellij idea رو بستم مجدد راه اندازی کردم و wamp رو هم restart کردم اما باز مثل قبله. (3 هفته پیش)
0 0
مطمئن شوید که short_open_tag = Off را تغییر داده باشید. چون قبلش یکی مثل این هست که در واقع اون نیست بلکه دومی هست پس به دنبال این نوشته بگردید و مقدار off را به On تغییر دهید و تنها restart کردن wamp کفایت میکند. (3 هفته پیش)
+1 0
در خطوط 149 و 200 این عبارت وجود داره که اولی به صورت کامنت هست و دومی (خط 200) نوشته short_open_tag=Off که باید بشه On مطابق آموزش که انجام دادم. الآن دوباره پلاگین ini4idea رو uninstal و دوباره نصب کردم یکبار با فایل موجود در پوشه tools از disk4 یکبار هم همون فایلو از سایت jetbrains دانلود و نصب کردم و هر بار wamp رو restart کردم اما بی فایده با این تفاوت که قبلا هیچی چاپ نمیکرد اما الآن موقع اجرا کد php نوشته شده رو تو مرورگر نشون میده! اینکه wamp رو تو درایو c نصب کردم و intellijidea رو تو یه درایو دیگه که ربطی به این موضوع نداره درسته؟ (3 هفته پیش)
0 0
خیر اگر در wamp خود مسیر پروژه ها را قرار داده اید مشکلی نیست. در فایل httpd.conf میتوانید آنرا طبق آموزش تنظیم کنید. (3 هفته پیش)
+1 0
شما باید تنظیمات intellej idea که استاد در فایل آموزش ها قرار داده رو از طریق File > Import Settings رو به برنامه بدید این تنظیمات با پسوند .jar هست و داخل انجمن هم سرچ کنید میتونید اونو پیدا کنید (3 هفته پیش)
+1 0
ممنون از راهنمایی های دوستان و زمانی که صرف کردید. فایل settings.jar توو مرحله قبل، import شد و یکسری از مشکلات حل شد اما این مشکلو حل نکرد (3 هفته پیش)
0 0
آیا طبق آموزش ها مسیر پروژه های خود را در فایلی که گفتم نوشتید؟ (3 هفته پیش)
 برای این سوال 1 پاسخ وجود دارد.
پاسخ به سوال 
libcode  3 هفته پیش
0 0

به این شکل عمل کنید. مسیر پروژه ها را درفایل httpd.conf تعریف کنید. و سپس wamp خود را restart کنید. خطوط زیر را اضافه کنید.مشکل حل خواهد شد. اگر wamp شما به رنگ سبز در بیاید.

<Directory "d:/dev/project/web/">
Options Indexes FollowSymLinks
AllowOverride all
Require local
</Directory>

پاسخگویی و مشاهده پاسخ های این سوال تنها برای اعضای ویژه سایت امکان پذیر است .
چنانچه تمایل دارید به همه بخش ها دسترسی داشته باشید میتوانید از این بخش لایسنس این آموزش را خریداری نمایید .